Bug (Using The Door From Level 2 to Level 1)


I was passing from level 2 to Level 1, something I've done at least once before on this character and got hit with "Unknown Application Error" (didn't read the error dialog title bar) - it was followed with a "String Library: Invalid Library Format" dialog.

Tried to Exit and Continue, same errors - except this time there was an additional "Cursor Error" dialog box.

Reset the PC, restarted Exanima, same thing.

I thought my characters might both be corrupted so I tried New Game, set up another character. That worked, but trying to Continue the character (who bugged) resulted in the same errors, but with a lot more Cursor Errors.

At which point I deleted the third (temporary test) character, except the character with the bug got vaporized too for some reason...leaving just one character remaining (character #2).

Continue works for him, he seems to load ok. I'll try playing around with it a bit more to see if he's stable.


I think I might have mangled it :oops:

I seem to remember my characters had both *.rsg and *.rcp files associated with them. I can't remember what they actually did but they were about 2Mb each.

Things currently appear to work ok from a practical perspective, but now my (new) characters only have a *.rsg file of about 750Kb associated with them - there is no *.rcp file at all. I verified game files using Steam and made another character, same thing. Renamed Exanima.set file and made another character, same thing (although all my global xps disappeared when I did that).

The only thing I was doing out of the ordinary before this occurred was compiling a large Journal, I had perhaps 40 entries, many scrolled off the bottom of the screen. I basically typed all the stuff in books/notes straight into the Journal and added some other stuff too (so I could leave all notes/books in situ). There was quite a bit of Alt-Tabbing going on (as I backed the Journal up in a text file).

I've got a bad feeling I Journalled Exanima to death :D


It seems to be fixed.

The *.rcp files are checkpoint files so they don't get created until Level 4.
The *.rsg files are save game files which start off around 750Kb and grow to maybe 2Mb/3Mb.
The Examina.set file seems to handle xps, and maybe other environmental stuff.

So everything seems to be working correctly now. Hopefully it was just a one-off glitch.


Project Lead
Is the save file for the bugged character gone? If not you could send it to us and we could look into what might have caused this.


Unfortunately there are no saves for the bugged character.

Initially I had two characters, the bug got character #1 and I could not use Continue. I thought the game files might have been corrupted. So I used New Game to start character #3 (to give me a way to get to character #2), which seemed to work. Except then I deleted character #3, at which point character #1 got deleted too.

I wasn't really thinking. If I encounter bugs again I'll copy the directory before I start fiddling with it.


© Copyright 2019 Bare Mettle Entertainment Ltd. All rights reserved.